Jump to content
Product Design Forums

Treasurebox
Sign in to follow this  
cash68

Solidworks: Cannot Move Part In Assembly

Recommended Posts

I try to move it, and it says "Selected component is fully defined. It cannot be moved."

 

When I edit the part, I can't find any outside reference to other parts, I'm not sure why it is fully defined. I don't get it. How do I fix this?

Share this post


Link to post
Share on other sites
Guest Shift1313
I try to move it, and it says "Selected component is fully defined. It cannot be moved."

 

When I edit the part, I can't find any outside reference to other parts, I'm not sure why it is fully defined. I don't get it. How do I fix this?

 

 

What relations do you have on the part? Can you post a screen shot of what you are working with. In the feature tree is there a (f) next to that part name? The first part in an assembly is "fixed" automatically. You can right click on it and select "float". Other than that, if you have no references between parts and the mates youve added havent mechanically locked the part im not sure.

Share this post


Link to post
Share on other sites
Guest bildder

If there is no context (like mate "in place") or other mates which fully define this part try to supress and next unsupress in design tree - sometimes can help.

Share this post


Link to post
Share on other sites
Guest Bowl of Soup

Yeah, this is usually an over definition of the mates in the assembly, but if you actually have no mating, then I'm not sure.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.